WordPress PHP versie updaten

WordPress PHP versie updaten

PHP versie updaten WordPress

Als je WordPress-gebruiker bent, zul je wellicht deze melding zijn tegengekomen: “PHP update aanbevolen”. Vervolgens zal WordPress aangeven: “Je site draait op een onveilige versie van PHP (x.x.xx), welke geüpdatet zou moeten worden”.

Maar hoe update je de PHP-versie van je website? Dat zal ik in dit artikel proberen uit te leggen.

WordPress PHP update
Deze melding zou je kunnen zien wanneer je een onveilige versie van PHP gebruikt.

Wat is PHP en waarom moet ik het updaten?

Voordat we beginnen: je zult je wellicht afvragen wat PHP eigenlijk is én waarom je PHP in hemelsnaam moet updaten.

PHP is een recursief acroniem (dat mag je overigens meteen weer vergeten 😉 ) voor PHP: Hypertext Preprocessor. PHP is de programmeertaal waarmee WordPress is ontwikkeld.

Net als bij software zoals WordPress, komen er regelmatig updates voor PHP. Deze updates komen de veiligheid én de performance (snelheid) ten goede. De laatste versie van PHP is PHP 8. Deze versie is nog lang niet bij alle hostingpartijen beschikbaar, en WordPress werkt nog niet helemaal goed met PHP 8. Zeker niet als je custom plugins en themes gebruikt kun je beter nog niet naar PHP 8 overstappen.

Gelukkig is het bij PHP ook niet zo dat je altijd meteen de laatste versie nodig hebt op het moment dat deze gereleased wordt. Kijk hier bijvoorbeeld eens tot wanneer welke versie van PHP ondersteund zal worden. Zo kun je zien dat PHP 7.4 (de voorganger van PHP 8) nog “active support” heeft tot 28 november 2021 en “security support” tot een jaar later (28 november 2022). Voor PHP 7.3 is er nog wel security support, maar geen active support meer.

Active support houdt in dat gerapporteerde bugs nog opgelost worden. Security support betekent dat alleen kritieke veiligheidsproblemen nog worden opgelost.

Ondersteunde versies van PHP
Tijdlijn van ondersteunde versies van PHP

Zoals je hierboven kunt zien betekent dat dat PHP 5.6 tot en met 7.2 (rood gekleurd) niet meer ondersteund worden. Voor PHP 7.3 (oranje gekleurd) is nog “security support” en voor PHP 7.4 en 8 (groen gekleurd) is sprake van “active support”.

Dit betekent dus dat als jouw website nog op een versie van PHP draait die ouder is dan 7.3, er security issues zouden kunnen ontstaan waarvan we weten dat ze niet meer opgelost gaan worden. Reden genoeg dus om te zorgen dat je (WordPress-)site minimaal op PHP 7.3 draait! Maar het liefst PHP 7.4 of zelfs 8 natuurlijk.

De reden dat oudere versies “gradueel” uitgefaseerd worden en niet van de ene op de andere dag is om ontwikkelaars (zoals die van WordPress of andere software) tijd te geven hun software aan te passen aan de nieuwe versie van PHP. Het kan bijvoorbeeld zijn dat dingen die in PHP 5.6 op een bepaalde manier werkten in versie 7.4 heel anders in elkaar moeten zitten.

WordPress PHP updaten: hoe doe je dat?

Je zult je inmiddels afvragen hoe je de PHP-versie van je WordPress-site kunt updaten.

Maak eerst een backup

Voordat je begint adviseer ik om eerst een backup te maken van je WordPress-site. Nou is het meestal zo dat als er iets fout gaat door te switchen naar een nieuwe PHP-versie, de oplossing vrij eenvoudig is; terug naar de vorige PHP-versie. Toch kan het nooit kwaad om een backup te maken van je website voordat je met dit soort wijzigingen begint. Een goede hostingpartij maakt overigens automatisch backups van je website (minstens één per dag) of biedt een mogelijkheid om met één klik een backup te maken.

Update WordPress, plugins en themes

Voordat je de PHP-versie verandert, is het meestal handig om eerst WordPress te updaten naar de nieuwste versie. Ook plugins en themes kun je het beste updaten. De nieuwste versies zijn vaak ook het beste compatibel met de nieuwere versies van PHP.

Je kunt ook de PHP Compatibility Checker plugin installeren die een scan kan doen. Helaas werkt deze plugin slechts tot en met PHP 7.3 en niet met het nieuwere PHP 7.4.

PHP Compatibility Scan
Compatibiliteit scanner van de PHP Compatibility Checker plugin

Controlepaneel

Helaas kun je PHP niet updaten vanuit je WordPress admin paneel. De server van je hostingpartij bepaalt namelijk de PHP-versie waarop je website draait. Niet iedere hostingpartij geeft klanten de mogelijkheid om zelf de PHP-versie aan te passen. De hostingpartij waar ik deze website heb ondergebracht (iXL Hosting) doet dat wel en ook Savvii laat klanten zelf de PHP-versie aanpassen.

Bij Savvii kun je je PHP-versie aanpassen met een simpel menu in het klantenpaneel

Zit je bij een hostingpartij waar je de PHP-versie niet kan aanpassen via een klantenpaneel? Dan zul je wellicht in het controlepaneel van je hosting moeten inloggen. In mijn geval is dat DirectAdmin, maar het kan ook Plesk zijn of een ander controlepaneel.

DirectAdmin

Om je PHP-versie aan te passen in DirectAdmin, log je in en klik je op “Domain Administration”.

DirectAdmin Domain Administration

Vervolgens klik je in het overzicht op de domeinnaam:

Klik op je domeinnaam
Klik op je domeinnaam

Je ziet nu een menu met verschillende instellingen. Helemaal onderaan vind je de PHP-instellingen – tenminste als je hostingpartij deze beschikbaar heeft gemaakt.

PHP instellingen

Onder het “Handler” menu vind je de mogelijkheid om de PHP-versie te selecteren. Bij iXL Hosting heb ik de mogelijkheid om te kiezen voor PHP 5.6, 7.1, 7.2 en 7.3:

Ik adviseer om de meest recente PHP 7-versie te selecteren.

Staat PHP 8 al in het lijstje? Ik adviseer om hier nog even mee te wachten. Het zou zomaar kunnen dat je plugins of themes gebruikt die (nog) niet werken met PHP 8. Het zal nog een tijdje duren voordat alle developers hun plugins en themes hebben aangepast aan PHP 8. Versie 8 van PHP is namelijk een behoorlijk ingrijpende update ten opzichte van 7.4.

Plesk

Gebruikt jouw hostingpartij Plesk als controlepaneel? Ga dan naar Websites & Domains en zoek je domeinnaam. Bij de details van je domeinnaam vind je onder andere welke PHP-versie er actief is. Klik daar vervolgens op om naar de pagina te gaan waar je de PHP-versie kunt wijzigen.

Plesk PHP versie wijzigen
De PHP-versie wijzigen in Plesk (screenshot van Plesk.com)

Selecteer de versie die je wilt activeren en klik vervolgens op de “Apply”-knop helemaal onderin het scherm.

Als je de PHP-versie niet zelf kunt aanpassen

Bij sommige hostingpartijen kun je niet zelf de PHP-versie aanpassen. WordPress laat de melding pas zien als je een écht verouderde PHP-versie gebruikt (zoals 7.1).

Huidige PHP-versie achterhalen

Hoe kom je er dan achter welke PHP-versie er gebruikt wordt op jouw server? Log in bij WordPress en ga naar je Dashboard. Zoek hier naar het kopje “Status Sitediagnose”:

WordPress sitediagnose
Sitediagnose

Hier staat meestal een link bij naar eventuele verbeterpunten op je website en/of hostingpartij. In de screenshot hierboven zie je die niet omdat ik op alle punten geslaagd ben (of nou ja, mijn website 😉 ). Je kunt echter nog steeds het diagnose-scherm bereiken door naar jouwwebsite.nl/wp-admin/site-health.php te gaan. Je kunt hier vervolgens het menu “Geslaagde tests” openklappen om te zien welke PHP-versie je gebruikt:

Geslaagde tests WordPress site diagnose
Deze website gebruikt PHP 7.4.18

Wat te doen bij een verouderde PHP-versie

Is jouw website niet geslaagd voor deze test, en gebruikt deze bijvoorbeeld PHP 7.1? En kun je de PHP versie niet zelf updaten bij jouw hostingpartij? Dan adviseer ik om je hostingpartij een e-mail te sturen met het verzoek om te updaten naar (minimaal) PHP versie 7.4. De meeste (goede) hostingpartijen kunnen de PHP-versie vrij eenvoudig voor je aanpassen, dus dit zou geen groot probleem moeten zijn.

Tot slot

Houd in de gaten welke PHP-versie jij gebruikt. Je hoeft niet wekelijks of zelfs maandelijks naar je PHP-versie te kijken. Maar het is zeker geen slecht idee om af en toe even te controleren of je PHP-versie nog wel ondersteund wordt. Gelukkig zal WordPress je via het Dashboard (“sitediagnose”) actief op de hoogte houden van eventuele problemen, ook rondom je PHP-versie.

Geschreven door
Wouter Postma
Reageer

Menu